Macbook Pro 15" Mid 2010 USB, Kernel Panic and RAM Repair and Upgrade

Our MacBook Pro had a few issues, it was a bit slow, one of the USB ports was not working, had the occasional kernel panic and the battery would drain overnight while it was in sleep mode. We had a look around at Banana IT, Powerbuy etc but all the laptops around the 25 to 35k Baht range were pretty unimpressive and when converting the price back to dollars and comparing the exact same models to the prices on Amazon they were $200 to $400 USD more expensive in retail Thailand than from Amazon. The shipping and import fees were around the $100 to $150 dollar mark so still less than buying one here in Bangkok. I almost ordered a Dell XPS 15" from Amazon, where the price difference was $650, the only thing that held me back was concern with the warranty. There was no way I was going to pay that much more to buy one retail in Thailand, I’d rather wait till I went to the US or Australia.

So after that bit of frustration I decided to see what I could do with my 9 year old MacBook. It is still a thing of beauty and when working properly a real pleasure to use, the screens perfect, basically not a scratch on it. It has a 2.3 Ghz i5, 500Gb HD but only had 4Gb RAM.

The first thing I did was upgrade the RAM, the max that model will take is 8GB, specifically 2 sticks of 4GB PC3 DD43 1066MHZ. First I tried Pantip on Ngamm Wong Wan road but couldn’t find it there so then tried Lazada and Dr Macbook but both were pretty expensive at around 3500 baht so I then checked on Amazon and the grand total including shipping came to 1300 baht. So ordered that, installed it and the kernel panic was fixed and it was a lot faster.
IMG_3916
RAM Done.
Here is the link on Amazon

Next issue was the fast battery drain, the battery cycle count was 440 cycles way less than the expected life of 1000 cycles, but when just using it normally on battery, no games just using safari, email, numbers etc it would drain in a few hours and then of course continue to drain while in sleep mode. I knew it was possible there was a short circuit around the USB port that was not working but I decided to just go ahead and get a new battery, this time Dr MacBook, a repair shop in Bangkok came in about the same price as Amazon so I just went ahead and order it locally. They delivered COD so that was great.
Here is the link to the Dr MacBook shop

They are very easy to get into, its just a matter of removing the phillips head screws around the perimeter on the bottom.
IMG_3918

Unfortunately the new battery didn’t solve the drain problem, it was still losing ~80% of its charge overnight. So now I had to decide if I was going to attempt to repair the logic board or take it to Dr MacBook. The idea of leaving it for repair was a bit concerning, the hard disk is encrypted, but they would still have to turn it on and login at which point the hard disk is not encrypted, I could create a non admin account for them to login to but I’m not exactly sure how difficult it is to get at the admin settings from a user account. The techs would also be plugging thumb drives into it that had probably been plugged into 1000’s of other machines that have been god only knows where. I was also concerned about any banking or financial information that may have been left somewhere on it, you could clear the browser history and remove receipts etc but it’s hard to know that you got every last breadcrumb as it were. Lastly I didn’t want to clear the keychain or install a fresh OS because I have a bunch of developer certs, distribution certs and encryption keys as well as a bunch of custom software that takes a long time to configure.

So I decided to give it a go myself and I am glad I did. After watching a couple of vids on youtube about various logic board repairs I figured the first thing to do was test the A8 JM capacitor on the non functioning USB port, set the multimeter to 80k ohm and there was no resistance between the two legs, tested the capacitor on the functioning USB port and the resistance climbed to infinity as expected for a cap. So there it was the first thing I tested seemed to be the problem. I know what a cap does but am not exactly sure what it’s function is in the USB signal/ wiring bus. An educated guess is that it might be involved in filtering or it could be to provide power as the laptop goes from mains power to battery. Either way I figured I would just remove it and not use that port.

IMG_3909%20copy

Done and done, it’s now working better than when it was new and I’m absolutely stoked. The USB port is also working again, at least with thumb drives, not sure what would happen if it had to spin up a hard drive.

1 Like

Booyakasha, it is awesome when things like that just work out.